We're continuing to monitor system stability as AWS fully recovers from their regional incident. Some backend processes may experience minor delays as queued data clears. At this time all systems are operational.
Posted Oct 20, 2025 - 16:03 MDT
Monitoring
We are continuing efforts to fully restore the iFIT experience.
Posted Oct 20, 2025 - 15:16 MDT
Identified
We are experiencing an authentication outage that is broadly impacting iFIT members.
Posted Oct 20, 2025 - 14:05 MDT
Update
We are continuing efforts to fully restore the iFIT experience.
Posted Oct 20, 2025 - 11:04 MDT
Update
We continue to see improvements across the iFIT platform. We are aware that an outstanding issue is causing a delay in activity log ingestion after workouts.
Posted Oct 20, 2025 - 05:59 MDT
Monitoring
We are seeing significant signs of recovery. We continue work towards full restoration of iFIT systems.
Posted Oct 20, 2025 - 04:31 MDT
Identified
We have identified the issue and are actively working with our upstream cloud provider to fully restore service.
Posted Oct 20, 2025 - 02:46 MDT
Investigating
We are investigating intermittent spikes in error rates across the platform.
Posted Oct 20, 2025 - 01:49 MDT
This incident affected: Workout, Login, Website, and China API.