Elevated Error Rate on Website
Incident Report for iFit
Resolved
The affected resources have continued to report latency and error rate metrics within normal ranges. This incident has been resolved.
Posted Jan 21, 2020 - 00:30 MST
Monitoring
This issue is now under control and we do not expect users to be affected at this time. We have applied minor configuration changes and are working on a fix for the issue that we believe caused this incident. We will continue monitoring all affected resources.
Posted Jan 20, 2020 - 23:19 MST
Update
We are continuing to work on this issue. We are seeing intermittent latency spikes on workout APIs. During these spikes, some users may experience latency and intermittent errors. We apologize for the inconvenience and will provide further updates as they become available.
Posted Jan 20, 2020 - 19:35 MST
Identified
This issue stems from latency on one of our APIs that is leading to an increased number of concurrent executions and ultimately throttling on some lambda functions that consume said API. We are currently working on this issue.
Posted Jan 20, 2020 - 18:15 MST
Investigating
We are currently investigating an issue that is causing an increased error rate on the website. We are also seeing increased API latency at this time.
Posted Jan 20, 2020 - 17:44 MST