API latency
Incident Report for iFit
Resolved
In the short term, we have made of configuration changes to our autoscaling group so that this issue will not occur again. We are working on a longer-term solution that will involve improved caching to reduce the load on our servers.
Posted Mar 23, 2020 - 14:36 MDT
Monitoring
We have identified the cause of the high latency on our API. A default configuration in the autoscaling group caused the number of available instances to decrease and lead to high latency and load on the remaining instances. The issue has self-corrected and we are exploring options to mitigate risk of this re-occurring in the future.
Posted Mar 23, 2020 - 14:05 MDT
Update
We are investigating high latency that is effecting our API.
Posted Mar 23, 2020 - 12:19 MDT
Investigating
We are currently investigating this issue.
Posted Mar 23, 2020 - 12:18 MDT